Client login

Icon

IMPORTANT ANNOUNCEMENT

Mandated PCI-DSS security update to TLS v1.2

Please be aware that due to the PCI-DSS mandated update to TLS v1.2, any connection attempts to our services using earlier versions of TLS will not be accepted from 6th June 2018 for Private Sector customers and 20th June 2018 for Public Sector customers. Please liaise with your technical team to ensure this standard is being met. If any further information or assistance is required then please contact the Pay360 Service Desk.

Icon

PAY360

Are you displaying the Pay360 logo on your website?

If you’re not, you could be losing out on lost sales due to cardholder security concerns. Why not associate your business with the trust, reliability and security offered by Pay360? Our payment solutions are secured to the highest industry standards and can help reassure your customers they’re in safe hands.